Manual/Studio Overview/Interface/Home

Revision as of 00:01, 23 June 2015 by UristMcSparks (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)



The Home tab contains basic functions necessary for building and testing your game.

HomeTab.PNG

Clipboard

The Clipboard lets you copy instances inside Studio.

Action Description
Paste Creates a copy of the copied/cut Instance(s) in the clipboard and pastes them in the selected Instance.
Copy Copies the selected Instance(s) to the clipboard.
Cut Copies the selected Instance(s) to the clipboard and deletes the original.
Duplicate Immediately copies the selected Instance(s) and parent's the copy at the same level as the original.

Tools

The Tools menu contains tools to manipulate the position, size, and orientation of Parts.

Action Description
Select Allows you to drag the current selection in the Workspace.
Move Displays three handles which can be dragged to move the current selection along the corresponding X, Y, or Z axis.
Scale Displays three handles which can be dragged to resize the current selection along the corresponding X, Y, or Z axis. Only works with BaseParts (Models cannot be scaled).
Rotate Displays three handles which can be dragged to spin the current selection about the corresponding X, Y, or Z axis.
1 Stud Sets dragging and scaling with Select, Move, and Scale to step in 1 stud increments. Sets Rotate to spin in 45 degree increments.
1/5th Stud Sets dragging and scaling with Select, Move, and Scale to step in 1/5th stud increments. Sets Rotate to spin in 15 degree increments.
Off Removes increments from other tools, allowing selections to be moved, scaled, and rotated freely.
Tip: By default Move will allow you to move a Part along the X, Y, and Z axes of the Workspace. If a Part is rotated, you can make it move along its local axes by pressing Ctrl+L. You can toggle back to moving it along the world's axes by pressing Ctrl+L again.
Tip: Sometimes you will want to manipulate an individual Part inside of a Model. A simple way to do this is to hold down Alt and then click on the Part. This lets you select that Part without selecting the entire Model.

Insert

The Insert menu contains tools to open the Toolbox and insert basic Parts.

Action Description
Toolbox Toggles the Toolbox window open and closed. This contains all of your Models and Decals, as well as all of the models in Roblox's library.
Part Inserts a 4x1x2 Part into the Workspace. The dropdown allows you to insert a Sphere, Wedge, or Cylinder instead of a Part.

Edit

The Edit menu allows you to change surface properties of parts as well as grouping parts.

Action Description
Material Changes the Material of the selected Part or Parts.
Color Changes the Color of the selected Part or Parts.
Surface Creates a tool to change the SurfaceType of the face of a Part. This can be used to hold parts together or create simple mechanisms (see Joints for more detail.
Group Moves all of the selected Parts into a new Model.
Ungroup Removes the Model group and allows all of the Parts that were in the Model to be selected individually.
Anchor Toggles whether Parts are Anchored or not. Anchored parts cannot move due to physics while the game is running.

Test

The Test menu lets you simulate your game to test it.

Action Description
Play Starts simulating the game and inserts your character. The drop down allows you to select Run which will start simulating the place but will not insert your character.
Stop Stops simulation of the game and resets all Parts and Instances of the the game to how they were before Play or Run was pressed.